Как в excel сделать ссылку на ячейку листа


Как в excel сделать ссылку на ячейку листа

Как в excel сделать ссылку на ячейку листа

Как в excel сделать ссылку на ячейку листа



Копирование и перемещение ячеек с формулами сравнимо с копированием и перемещением обычных ячоск, но результат не всегда аналогичен. Например, рис. 1.2 содержит пример расчета баланса фирмы за несколько месяцев. Формула в ячейке С9 с помощью функции СУММ() осуществляет суммирование расходов за январь (диапазон С5:С8).
Далее необходимо рассчитать расходы за следующие месяцы (февраль и март). Вы можете просто создать новые формулы, но есть способ выполнить эту задачу гораздо проще и быстрее, скопировав формулу из ячейки С9. Рис. 1.3 демонстрирует результаты копирования содержимого ячейки С9 в D9.

Рис. 1.2. Суммирование расходов за январь

Рис. 1.2. Суммирование расходов за январь

Как вы можете видеть, Excel автоматически корректирует диапазон вычисления, и теперь формула в D9 автоматически приняла вид =СУММ(D5:D8). Как же Excel узнал о необходимости корректировки диапазона? Для ответа на этот вопрос вам необходимо узнать об относительных ссылках в Excel.

Рис. 1.3. Результаты копирования содержимого ячейки

Рис. 1.3. Результаты копирования содержимого ячейки

Относительный формат ссылок (относительные адреса ячеек)

Когда вы используете указание на ячейку в формуле, Excel выбирает ячейку относительно текущей ячейки (в которой находится формула). Например, представьте, что у вас есть формула =А12 в ячейке A3. Для Excel такая формула звучит как: «Умножить содержимое ячейки, находящейся на две строчки выше, на число два». Это называется относительным форматом ссылки, и он является стандартным для Excel. Это означает, что если вы скопируете эту формулу в ячейку А4, относительный формат ссылки по-прежнему будет говорить: «Умножить содержимое ячейки, находящейся на две строчки выше, на число два», но формула, разумеется, при этом меняется на =А22, потому что ячейка А2 на две строки выше текущей ячейки А4.

Как вы уже видели из рис. 1.2 и 1.3, при таком копировании все идет достаточно хорошо. Но давайте рассмотрим другой пример. Например, вы хотите также запланировать дополнительные расходы фирмы и указываете, что они равны 3% (см. рис. 1.4). В ячейку С11 мы помещаем число 1.03 для указания дополнительных расходов. Теперь наша формула расходов за месяц становится =СУММ(С5:С8)С11. Попробуем скопировать данную формулу для вычисления расходов за февраль. Теперь ячейка D9 показывает нам значение 0! (см. рис. 1.4).

Почему произошла данная ошибка? Изучение формулы в ячейке D9 показывает нам, что Excel автоматически сделал ее равной =СУММ(D5:D8)D11. Разумеется, у нас нет никакого значения в ячейке D11. Поэтому и результат становится равным 0. Вся проблема здесь в относительной адресации ссылок. Когда происходит копирование формулы, Excel также меняет адрес С11 на D11. Для того чтобы устранить данную проблему, необходимо обратиться к абсолютной адресации ссылок.

Excel автоматически не перестраивает относительные ссылки, если вы перемещаете формулу. По замыслу программы, вам этого не требуется.

http://tandem-direct.ru/

Рис. 1.4. Введение дополнительного поля и появляющаяся ошибка

Абсолютный формат ссылок (абсолютные адреса ячеек)

Когда вы используете абсолютную адресацию ссылок, Excel использует ее для вычисления физического адреса ячейки. Для указания программе, что вы хотите использовать абсолютный формат ссылки на ячейку, используется знак доллара ($). Вы можете использовать его перед указанием строки ^или столбца. Например, формула =$A будет интерпретирована Ехeel как «умножить содержимое ячейки А1 на два». Неважно, будете ли вы копировать или перемещать данную формулу, ничего не изменится. Адрес ячейки будет оставаться тем же самым.

Итак, для исправления ошибки на рис. 1.4 вы должны зафиксировать значение в ячейке C11. Для этого вам необходимо переписать самую первую формулу для января следующим образом: =СУММ(С5:С8)$C. После данных изменений ВЫ можете спокойно копировать формулу в другие ячейки. Для февраля скопированная формула будет иметь вид =СУММ(D5:D8)$С, что дает верный результат вычисления. Также вы должны знать о том, что вы можете вводить адреса ссылок, используя смешанный формат. В данном случае вы сможете зафиксировать или строку, или столбец.

Для фиксации строки используйте знак доллара перед числом, например В. Для фиксации столбца введите знак доллара перед буквой столбца, например $В6.

При вводе формулы вы можете быстро переключаться между форматами адресации ссылки. Для этого используйте горячую клавишу F4. Нажимая на нее, вы будете поочередно получать знаки доллара в различных местах адреса ячейки.

Копирование формулы без изменения при относительном формате ссылки

Если вы хотите скопировать формулу ячейки без изменений, но при этом в формуле есть ссылки на ячейки в относительном формате, вы можете проделать следующее:

  1. Выберите мышкой ячейку с формулой, необходимой для копирования.
  2. Щелкните мышкой внутри строки для ввода формулы.
  3. Используйте мышь или клавиатуру для выделения формулы.
  4. Скопируйте выделенный текст формулы.
  5. Нажмите Esc для выхода из режима редактирования формулы.
  6. Выделите ту ячейку, в которую вы хотите скопировать формулу.
  7. Вставьте формулу.

Источник: http://excelexpert.ru/kak-v-excel-kopirovat-i-peremeshhat-formuly


Как в excel сделать ссылку на ячейку листа

Как в excel сделать ссылку на ячейку листа

Как в excel сделать ссылку на ячейку листа

Как в excel сделать ссылку на ячейку листа

Как в excel сделать ссылку на ячейку листа

Как в excel сделать ссылку на ячейку листа

Как в excel сделать ссылку на ячейку листа

Как в excel сделать ссылку на ячейку листа

Новое на сайте: